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1. Migration Basics 

1.1. Overview 

A data migration is defined as the process of transferring data from one location to another.  A 
determination of what exams should be moved is made and a list of exams to move are collected and 
subsequently moved.  To ensure that the exam was processed properly by the destination, a query may 
be issued to the destination to verify the existence and/or validity of the exam. 

1.2. Workflow 

DICOM migrations function through a set of third party commands that allow a client to interrogate an 
archive for content and then selectively issue move requests to transfer that data to another system.  In 
the simplest case, the third party client never sees the actual data: 

If the data needs to be changed in any way (also known as “filtering”) it must pass through a system that 
can do so.  The main difference is that the move destination as far as the source is concerned is the 
system that will do the filtering.  This filtering system is responsible for forwarding the image on to the 
final destination: 

2. Installation 

2.1. Prerequisites 

Laurel Bridge Exodus utilizes several components known as prerequisites that must be installed for it to 
work.  The prerequisites consist of: 

Query/Move Request 

Image Transfer 

Exodus 

Source 
Archive 

Destination 
Archive 

Image Transfer 

Validate Request 

Query/Move Request 

Image Transfer 

Exodus 

Source 
Archive 

Destination 
Archive 

Validate Request 
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- Microsoft .NET Framework 2.0 
- Microsoft SQL Server 2005 Express 

 
The main install executable (setup.exe) will determine whether these prerequisites need to be installed 
and install them appropriately. 

2.2. Main Install 

After installing the prerequisites, the Exodus installer (Exodus.msi) will run.  For machines with an older 
version installed, this installer will upgrade your previous install appropriately while maintaining your 
configuration settings. 

3. Getting Started 

3.1. Overview 

Exodus manages migrations by creating a database known as a session that contains all the 
configuration information as well as all the state and tag information for every exam it knows about.  
Groups of exams are viewed and operated upon by creating configurable views known as segments 
within a session. 
 
A session represents a separate database that stores configuration information about a migration.  
Information about the source, destination, and validation archives is included, as well as settings for 
each of these operations (e.g. timeouts, schedules, delays, etc.).  In addition to this information, the list 
and state of every query and exam is contained within a session which represents the work that has 
been done for a given migration.  While multiple sessions can be configured, typically only one is needed 
for a given migration. 
 
A segment provides the definition of what to query and represents a logical grouping of exams to 
migrate based on those queries.  There are multiple types of segments available allowing for various 
methods by which to gather listings of exams to work on.  A given migration can be broken up into 
multiple segments or left as one segment representing the entirety of the migration. 

3.2. Types 

Exodus supports two types of migrations: File and Archive.  The type of migration defines where the 
source data is located.  For file-based migrations data is collected recursively from a directory and for 
archive-based migrations data is housed in a DICOM-compatible archive.  Both migrations are processed 
very similarly and have query phases where a list of exams is collected, move phases where the chosen 
exams are moved, and a validate phase where the moved exams are verified.  In fact, after indexing the 
information from the raw DICOM image files from disk into a built-in archive, file-based migrations 
function exactly like an archive-based one (i.e. – both are communicating with a source archive – one is 
simply built-in). 
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3.3. Editions 

Exodus comes in three editions: Basic, Standard, and Premium.  Information on which edition you are 
licensed for can be found by clicking Help > About Laurel Bridge Exodus.  Certain features described in 
this document may not be applicable depending on the edition you are using: 
 

- Premium: Includes all features listed including data filtering 
- Standard: Includes all features of Premium except data filtering. 
- Basic: Includes all features of Standard except the ability to perform moves. 

3.4. Charge By 

Exodus comes in two modes: Charge By Exam and Charge By Move.  Information on which mode you 
are licensed for can be found by clicking Help > About Laurel Bridge Exodus. 
 

- Charge By Exam: Licensed by number of exams (i.e. - a given exam can move multiple times and 
will only count against the total once). 

- Charge By Move: Licensed by number of moves (i.e. – a given exam can move multiple times, 
but will be counted against the total once for each move). 

3.5. Installing a License 

The first step after launching Exodus is to install a license.  When the registration dialog appears, click 
the License… button, browse to your license file, and hit OK.  Information on the status of your license, 
including when it expires, can be found on this dialog available at any time by clicking Help > About 
Laurel Bridge Exodus. 

3.6. Creating a Migration 

To begin using Exodus, you need to create a session to define the source and destination archives and at 
least one segment to define what queries you want to issue and the resulting exams you want to work 
on. 
 
To create a session, click File > New Session (or right-click in the Sessions / Segments panel and select 
New Session).  After you enter the desired session name a configuration dialog will appear that contains 
network settings for all the archives involved in the migration, alert settings for email notifications, and 
advanced settings for timeouts, rates, schedules, delays, try counts, etc.  Context help is available by 

clicking the  icon present next to each field in the dialog. 
 
To create a segment, select the new session and right-click New Segment in the Sessions / Segments 
panel.  After you enter the desired segment name a configuration dialog will appear that contains 
settings for the type, priority, and type-specific selection information.  Context help is available by 

clicking the  icon present next to each field in the dialog. 
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3.7. Running a Migration 

After creating a session and at least one segment you can begin a migration.  To do so, check mark the 
desired segments in the Sessions / Segments panel, check mark the appropriate operations at the 
bottom of the main dialog (Query, Move, and Validate), and click the Run button on the toolbar.  The 
progress bars on the bottom of the screen will reflect how far along each of the selected operations are.  
Once there are no more operations to complete, the migration will automatically stop. 
 
While the operations can be run independently of one another, they are still sequential.  At least one 
successful query has to complete before there can be any exams eligible to move.  Similarly, at least one 
successful move has to complete before there can be any exams eligible to validate. 

4. User Interface Details 

4.1. Sessions / Segments Panel 

The Sessions / Segments panel (shown in Figure 1) is available on the left hand side of the main window.  
It is a two-level tree control that contains the available sessions (top level) and each session’s available 
segments (bottom level). 
 
Only one session can be active at a time and is represented by bold text 
(Figure 1 shows example session 1 as the currently active session and 
example session 2 as an inactive session).  Only the active session 
displays its segments, each of which can be checked to select for 
viewing and running. 
 
When the migration is running, the checkboxes are replaced by icons 
representing the state of the segment.  A green icon means the segment 
is in progress.  A white icon means the segment is not currently loaded.  
A red icon means some unexpected error has occurred (dynamic 
segments only).  A black icon means that the segment is currently loaded 
and complete. 
 
The panel itself has a context menu (shown in Figure 2) available by right-
clicking any blank space within in. 
 

- New Session: Creates a new session 
- Import Session: Imports a session from a file 

 
Each session has a context menu (shown in Figure 3) available by right-
click.  Note: some options are disabled depending on whether the session 
is active or not and if multiple sessions are selected. 
 

- Open: Activate a session 
- New Segment: Create a new segment for a session 
- Save Report: Generate an import report (file-based only) or a 

Figure 1 - Sessions / Segment Panel 

Figure 3 - Session Context Menu 

Figure 2 - Sessions / Segment 
Panel Context Menu 
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progress report about all of the contained segments and their composite exams contained 
within a session 

- Export: Exports a session for backup 
- Clone: Creates a new session with the same settings and segments 
- Advanced: Perform advanced options including optimizing the database, resetting 

query/move/validate errors, and resetting all query/move/validate progress (to redo all work) 
- Delete: Delete a session 
- Rename: Rename a session 
- Properties: Display the session configuration dialog 

 
Each segment has a context menu (shown in Figure 4) available by right-
click.  Note, certain options are disabled if multiple segments are selected. 
 

- Save Report: Generate a progress report about the exams 
contained within a segment 

- Generate Sample: Creates a sample of representative data from 
the given segment (by date and modality) 

- Advanced: Perform advanced options including resetting 
query/move/validate errors and resetting all query/move/validate 
progress (to redo all work) 

- Delete: Delete a segment 
- Rename: Rename a segment 
- Properties: Display the segment configuration dialog 

4.2. Session Configuration Dialog 

The session configuration dialog (shown in Figure 5) contains all the connectivity and alert information 

about a migration.  Details about each entry field are available by clicking the  icon next to a particular 
field. 
 

- Network: The network contains the connectivity information for 
the source, destination, and validation archives, as well the 
modality worklist server.  The validation archive is the system 
that responds to query requests after an exam is moved and is 
often times the same physical machine as the destination archive 
(unless routing occurs, for example).  Press the advanced button 
to specify validation archive information if it is different from the 
destination archive.  Pressing the Test button while this tab is 
selected performs sample queries to the archives specified and 
indicates invalid entries by highlighting them in red. 
  

- General: The general tab contains the migration type (archive or 
file-based), migration level (study or series), reset window, and 
the alert information including email server configuration, alert 
recipient, and alert type information.  The migration type and level cannot be changed after the 
session is created.    Email alerts are sent out to the specified email addresses depending on 
what events occur and what alert types are registered for.  When a stop trigger (certain number 
of successive failed query, move, or validate operations) is reached alerts are sent out to email 

Figure 5  - Session Configuration 

Figure 4 - Segment Context Menu 
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addresses registered for Error Alerts.  When a new day is reached daily reports are sent out to 
email addresses registered for Daily Reports. 
 

- Query: The query tab contains specific information about the query operations including 
timeouts, try counts, delays, partitioning modes, and user defined tags.  User defined tags are 
non-standard tags that aren’t normally requested during a query.  Any DICOM tag can be 
queried.  See 6.1 for more details on the query operation including user defined tags. 
 

- Move: The move tab contains specific information about the query operations including 
timeouts, move order, pre-checks, try counts, delays, and schedule.  The move schedule is 
defined on a per hour basis with three basic modes: Normal, Off, and Rated.  During Rated 
mode, the configurable rate (given as a percentage) is used.  Right-clicking the move schedule 
will bring up a presets menu allowing you to select from popular schedule configurations.   See 
6.2 for more details on the move operation. 
 

- Validate: The validate tab contains specific information about the query operations including 
timeouts, try counts, delays, and rules.  Each validation rule consists of a set of options including 
the tags to use to find the exam on both the source and destination archives, level from which 
to obtain image count or list information for comparison, and comparison logic to use to 
compare the collected data (e.g. – equal to, greater than, etc).  See 6.3 for more details on the 
validate operation. 
 

- Filters: The filters tab (Premium edition only) contains the configuration window to create image 
filters to change any image information during the migration.  If image filtering is enabled all 
images are routed through Exodus (via C-STORE from the source) before being forwarded on the 
destination (via C-STORE to the destination).  The filtering mechanism can be configured to 
allow uncompressed, compressed, or both (via forcing the source to negotiate a particular 
transfer syntax).  
 

- Test Button: The test button initiates a series of connectivity and compatibility tests for the 
entered information.  Any errors will be highlighted in red and information provided.  It is 
recommended that any errors be addressed as they are likely the result of misconfiguration that 
will impede the migration or limit the information returned from the given archives. 

4.3. Segment Configuration Dialog 

The segment configuration dialog (shown in Figure 6) contains the 
information that defines a segment and the queries and exams it 
contains.  Each segment type has a different set of fields available that 
apply to that particular segment type.  Details about each entry field 

are available by clicking the  icon next to a particular field. 
 

- General: The general tab contains the segment type and 
general selection criteria for the segment.  The available types 
include Normal, Specific, List, Priors, and Fixed.  See section 5 
for more information on each segment type. 
 

o Normal: Provides a date range to query one day at a 

Figure 6 - Segment Configuration 
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time backwards through time 
o Specific: Provides specific patient data queried in a single query 
o List: Provides a list of exams to query and move provided by a file or command 
o Priors: Provides a set of patient matching requirements to use after querying for a list of 

patients from a modality worklist server or command-line output to then use to mach 
against the exams from a source archive 

o Fixed: Used as a simple fixed list of studies usually created by right-clicking an exam or 
set of exams and selecting “Add To Segment”. 

 
- Advanced: The advanced tab contains specialized selection criteria used to refine the segment 

definition explicitly.  Also available is a move schedule that can be optionally enabled which will 
override the global session move schedule.  The move schedule is defined on a per hour basis 
with three basic modes: Normal, Off, and Rated.  During Rated mode, the configurable rate 
(given as a percentage) is used.  Right-clicking the move schedule will bring up a presets menu 
allowing you to select from popular schedule configurations. 

4.4. Exam Viewer 

The exam viewer (shown in Figure 7) is 
available on the right hand side of the main 
window (if activated by clicking View > 
Exams) and contains a list of all the exams 
that are contained within any loaded 
segment (i.e. segments with a checkmark 
next to them). 
 
Columns can be reordered by dragging the column headers left or right 
within the viewer.  Columns can be sorted on by clicking on a particular 
column header.  The direction of the sort (i.e. ascending or descending) 
is toggled on each subsequent click.  Columns can be hidden by right-
clicking on any column header and using the menu that appears 
(shown by Figure 8) to toggle the visibility of a particular column. 
 
Each exam listed in the viewer has a context menu (shown in Figure 9) available by right click.  Note: 
certain options are disabled if configuration information about specific archives (e.g. source, destination, 
validate) is missing. 
 

- Move: Move selected exam(s) after setting to Waiting 
- Validate: Validate selected exam(s) after setting to Moved 
- Fetch: Move selected  exam(s) to local machine  
- Set Status: Override the selected exam(s) status (setting to a 

status of Validated will set the status to be Validated (0) to 
indicate that it was validated manually) 

- Add to Segment: Add the selected exam(s) to a new or existing 
list segment 

- View History: View move/validate history for selected exam 
- Copy: Copy the selected row(s)/cell text to the clipboard 
- Save: Save the selected exam(s) information to a file 

Figure 7 - Exam Viewer 

Figure 8 - Column Display Menu 

Figure 9 - Exam Menu 
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The exam search pane (shown in Figure 
10) is available above the exam viewer (if 
activated by clicking View > Exams Search 
or the small magnifying glass icon in the 
viewer title bar) and allows the list of 
exams displayed in the exam viewer to be limited by a set of match requirements.  This can be used to 
find a logical subset of all the loaded exams without defining a new segment.  Every column in the exam 
viewer can be used in the exam filter control with a number of match modes (e.g. Equal To, Greater 
Than, etc).  The exam filter control only limits the exams displayed.  It does not, however, change the 
loaded segment definitions.  Thus, if an exam is contained within a loaded segment it is still eligible to be 
moved and/or validated regardless of whether it is displayed in the viewer. 
 
To increase performance (especially when doing a large number of queries) the exam viewer can be 
locked (i.e. - disabled) by clicking the small lock icon in the viewer title bar.  

4.5. Query Viewer 

The query viewer is available on the right hand side of the main window (if activated by clicking View > 
Queries) and contains a list of all the queries that are contained within any loaded segment (i.e. 
segments with a checkmark next to them).  Column display, context menu options, searching, and 
locking are similar to the exam viewer.  See section 4.4 for more details. 

4.6. History Dialog 

The history dialog (shown in Figure 11) is 
available by right-clicking on a single exam or 
query and selecting View History.  The entire 
history for a given item is listed with the time 
and result along with any comments (typically 
error comments). 
 
For validate operations each rule for a given 
score attempted is listed as a separate 
operation.  For each try the information that 
was returned from the source and validation 
archives is listed to the right in the Results 
panel.  A short explanation as to why a validation operation failed or passed is given in the Comments 
box. 
 

4.7. Operation Progress Panel 

The operation progress panel 
(shown in Figure 12) is 
available at the bottom of 
the main window and is used 

Figure 12 - Operation Progress Panel 

Figure 11 ï Exam History Dialog 

Figure 10 - Exam Search Pane 
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to display the individual progress of the Query, Move, and Validate operations for the loaded segments.  
Each operation panel has a checkbox to control whether that operation will run when a migration is run.  
When running, these checkboxes are replaced by a spinning animation to indicate that a specific 
instance of a given operation (e.g. a single move) is occurring or a pulsing animation to indicate that a 
given operation is waiting for more work to do.  Progress is represented through a progress bar (blue for 
success and red for failure) as well as through numeric statistics below each progress bar.  The 
estimated amount of time remaining for a given operation is also available. 

4.8. Tool Bar 

The tool bar (shown in Figure 13) is available 
at the top of the main window and contains 
multiple buttons for controlling, configuring, 
and viewing a migration. 
 

-   Run : Starts a migration involving the selected operations on the loaded segments 

-   Stop: Stops a migration (prompts if operation currently in progress) 

-  [Session]: Displays the session context menu 

-  [Segment]: Displays the segment context menu 

-  [Record Log]: Starts full-detail logging to user-defined file for simplified debugging purposes 
 
In addition to these controls, an exam viewer row selector is available on the far right which displays the 
current selected row and the total number of rows displayed in the viewer. 

4.9. Menu Bar 

The menu bar (shown in Figure 14) is available at the top of the 
main window. 
 

- File > New Session: Creates a new session 
- File > Import Session: Imports a session from a file 
- File > Record Log: Starts full-detail logging to user-defined file 
- File > Exit: Exits the program (after stopping migration) 

 
- View > Queries: Toggles the display of the query viewer 
- View > Exams: Toggles the display of the exam viewer 
- View > Queries Search: Toggles the activation/display of the query search pane 
- View > Exams Search: Toggles the activation/display of the exam search pane 
- View > Sessions / Segments: Toggles the activation/display of the session/segments viewer 

 
- Tools > Query Client: Displays a query dialog that performs C-FIND requests 
- Tools > Log Viewer: Displays a log viewer dialog with display filtering options 
- Tools > Options: Displays an options dialog to set program options (e.g. – logging) 

 
- Help > Getting Started: Displays a guide on how get started with the program 
- Help > User Manual: Opens this user manual 

Figure 13 ï Tool Bar 

Figure 14 - Menu Bar 
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- Help > About Laurel Bridge Exodus: Displays an about dialog containing program and license 
information 

5. Segments 

5.1. Overview 

A segment provides the definition of what to query and represents a logical grouping of exams to 
migrate based on those queries.  There are multiple types of segments available allowing for various 
methods by which to gather listings of exams to work on.  The set of queries done to gather exams is not 
necessarily the same list of exams that will be contained within that query.  In other words, every exam 
returned by a given query won’t necessarily be part of the segment.  This is required because of the 
limited query functionality available in DICOM and in legacy archives.  A given migration can be broken 
up into multiple segments or left as one segment representing the entirety of the migration. 
 
All segment types have segment-specific criteria as well as shared criteria including a Name, Priority, 
Custom SQL Selection String, and Move Schedule Override (except in Basic editions). 

5.2. Normal 

Normal segments are the most typical segment type for a historical migration.  This segment type 
defines a Date range to query for: one day at a time with the most recent date first.  A Modality selector 
is also available with the option for Inclusive (i.e. – that modality is included in list of modalities) or 
Exclusive (i.e. – that modality is not included in list of modalities) logic. 

5.3. Specific 

Specific segments allow for selective information to be gathered from a single query.  In order to limit 
the query scope a selective piece of information that is to be queried for must be included: UID, 
Accession #, Patient Id, and/or Patient Name.  In addition, Date and Modality options are also available. 

5.4. List 

List segments allow for a list of exam UIDs to be provided.  Each UID in the list will be queried for to 
gather additional information about the exam.  Lists can be provided as either a File or as the output of 
a Command.  This list can be repopulated on a configurable Interval. 

5.5. Priors 

Priors segments allow a list of relevant prior exams to be gathered from a particular Date range.  Exams 
are considered to be priors when they match based on a configurable set of criteria to a list of upcoming 
exams that can be gathered from a Worklist server or from the standard output of a Command.  The set 
of tags that can be used include Patient Name, Patient Id, Patient Dob*, Patient Sex*, Modality, and 
Body Part* (* = when added as a user defined tag).  The matching modes between the upcoming exam 
list and potential prior exams include Exact (matches values that match exactly), Smart (matches values 
in a criteria specific manner to avoid minor inconsistencies common to that specific tag), Map (matches 
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values after translating upcoming exam values through a mapping given by a file), and Custom (matches 
values using a custom SQL string).  Priors exams are no longer considered priors after the upcoming 
exam they match has been off of the upcoming exam list, gathered at a given Interval, for more than the 
time given by the Fall Off time.  Each new exam can match a given number of matches specified by Max 
Matches.  The reset window (Charge By Move mode only) allows for exams to be reset to the Waiting 
state after a configured amount of time for use with transient/temporary destinations. 
 
Smart matching follows these guidelines for comparing upcoming exam values with potential prior exam 
values: 
 

- Patient Name: Matches when either name (after being stripped of spaces and carets) is a subset 
of the other (e.g. – SMITH^BOB^J matches SMITH^BOB) 

- Patient Id: Matches by ignoring leading zeros (e.g. – 0001234  matches 1234 ) 
- Patient Dob: Matches when dates differ by one day or less (e.g. – 19900101  matches 

19900102 ) 
- Patient Sex: Matches when first letter matches (e.g. – Male  matches M) 
- Modality: Matches when upcoming exam value in an item in the list of values in the prior exam 

(e.g. – MR matches MR\ CT) 
- Body Part: Matches when upcoming exam value in an item in the list of values in the prior exam 

(e.g. – CHEST matches CHEST\ HEAD) 
 
Map matching functions the same for all tags.  Matches occur when the upcoming exam value is 
contained within a list of keys in map file and the associated value for that key is contained within the 
list of values in the prior exam.  For example, if the upcoming exam has a value for Patient Id of 123456  
and the map file has a mapping for 123456  to 56789  then this will match any potential prior exam that 
has a Patient Id of 56789  and not one that has a value of 123456 .  As another example, if the upcoming 
exam has a value for Body Part of HEAD and the map file has a mapping for HEAD to BRAIN and HEAD to 
HEAD then this will match any potential prior exam that has a Body Part of HEAD or HEAD\ CHEST or 
BRAIN or BRAIN\ ARM, etc. 

5.6. Fixed 

Fixed segments allow for a simple user-defined list of studies that are added through the user interface 
(as opposed to a file of UIDs, for example).  These segments are usually created and managed by right-
clicking on an exam or set of exams and selecting “Add To Segment” and “Remove From Segment”.  

6. Operations 

6.1. Query 

Every segment definition results in a set of queries that are performed against the source archive one at 
a time.  Each query returns a set of exams that match the given query.  To protect against potential 
limitations, some queries are purposefully made more generic than might be expected.  The result of 
this is that not all of the exams that return necessarily match the segment definition.  However, 
regardless of the precision of the query, the resulting exams are post-processed to effectively discard 
any exams that don’t match the segment definition.  The end result is that any high level segment 
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definition results in the appropriate intelligent queries which will, in turn, provide the appropriate 
exams. 
 
Normally, the set of queries is defined at segment creation/modification time.  For dynamic segments 
like Priors and List, the query list changes periodically.  Thus, dynamic segments will never finish as far 
as the application is concerned.  Human assessment is required to determine when the dynamic 
segment is no longer needed.  For example, the Priors segment can fetch prior exams for any patient on 
the worklist server.  Since new patients can be added at any time, the segment is never truly complete.  
However, once all the exams on the source archive have been migrated, the segment is effectively 
complete.  This determination is not automatically made, but can be aided by the completeness of a 
secondary segment that contains a list of all the exams on the source archive. 
 
Queries are tried a configurable number of times (until success) with a configurable timeout.  Once a 
query is marked as failed it must be manually reset (available in the segment and session context 
menus).  The delay in between queries is also configurable.  In addition to the standard tags displayed in 
the exam viewer, any other tag, known as a user defined tag, can be requested during all queries.  These 
settings are found in the session configuration dialog. 
 
When migrating at the study level any user defined tag can have its query level overridden to the series 
level forcing a single query at the series level for each study returned in the base query.  The overridden 
tag will have its information coalesced from the information at the series level and grouped together by 
backslashes.  So, for example, if you wanted to fetch Body Part Examined, but you knew it was only 
available at the series level.  You would add a user defined tag for it (in the session configuration dialog) 
and override it by selecting the checkbox next to it.  The final returned studies to be stored in the 
internal database would contain the Body Part Examined values from the series level. 

6.2. Move 

Each segment is made up of exams that match the given segment definition.  Each exam contained in a 
segment is eligible for move provided its status is Waiting. 
 
Each move is tried a configurable number of times (until success) with a configurable timeout.  Moves 
are skipped (and marked as Moved) if the move pre-check score is configured and passes (the pre-check 
process is identical to the validation process and can be thought of as pre-move validation where a 
certain score must be met to skip the move).  The number of simultaneous moves is also configurable 
and may be limited due to configuration settings on the source archive.  The move schedule that defines 
the delay in between moves and when moves should not take place is also configurable on a per hour 
basis.  Delays are available in Rated mode and are a function of the percentage of the duration of the 
most recent move.  These settings are found in the session configuration dialog. 
 
Exams with failed move statuses can be reset individually by the exam viewer context menu or at the 
segment/session level through the segment and session context menus. 

6.3. Validate 

Each exam contained in a segment is eligible for validation provided its status is Moved (when using the 
Basic edition the necessary status is Waiting).  The purpose of validation is to ensure that exams were 
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successfully received and processed by the destination archive.  The validation archive can be, and 
generally is, the same archive as the destination unless the destination is a router or gateway. 
 
Validation consists of a set of rule with a given rank where each rule is processed (starting with rank 1) 
until a successful match is found.  The resulting validation rank is the highest (i.e. lowest numbered) rank 
for which a match occurred.  Thus, more stringent requirements should be used for higher ranks. 
 
The first step in validation is to locate each exam or set of exams on the source and destination archives.  
Each rule consists of a configurable set of tags specified by the Tags list that will be used as the match 
tags in the queries to the source and destination.  The matching values used are the values collected 
previously during the initial query phase of the migration.  Depending on which tags are used and the 
content of each archive, one or more exams may be returned from each archive.  In the ideal situation, 
validation would have one rule matching solely on the exam UID to return one result from each archive.  
However, since UIDs can potentially be changed during a migration either intentionally or otherwise, 
this is not always possible.  Choosing a different set of match tags can provide an alternate way of 
locating exams as well as ensuring that certain tags were not changed.  However, if one or more of those 
tag values are changed during migration that exam will not be located on the destination.  Thus, care 
should be taken to choose the appropriate tags that will ensure that exams will be located correctly. 
 
The next step is to determine from which level data will be obtained designated by the Level selection.  
The options include Study which is a count of the number of images in a particular study (Number of 
Study Related Instances), Series which is a count of the number of images in each of the series in a 
particular study (Number of Series Related Instances), and Image which is a list of all the images in a 
particular study (SOP Instance UID).  This decision is generally determined by the capabilities of the 
archives involved as some systems do not support certain options.  Image level validation is stricter as it 
requires that not only the counts match, but that the exact list of images are the same. 
 
The next step is to determine how the data collected is compared designated by the Comparison 
selection.  When retrieving count information (Study or Series), the options for comparison are 
numerical based (e.g. - Equal To, Greater Than, Less Than or Equal To, etc) and list based (e.g. – Equal 
To, Contains, etc) when retrieving list information (Image).  Note, that if either the source of the 
destination is set to return count information, numerical based comparisons are used as the list data is 
converted to count data for comparison (e.g. – a list of 5 images will be converted to “5”).  This allows 
for flexibility in terms of the comparison such that, for example, any exam that has at least as many 
images for a particular study on the validation archive as on the source archive can be considered a 
match.  The options should be read as “results from source archive are <option> the results from the 
validation archive”.  
 
The last step is to determine how duplicates and multiple responses are processed, if allowed, 
designated by the Duplicates and Multiples selections.  When retrieving count information (e.g. – Study 
Image Count), the options are numerical based (e.g. – Sum, Max, Min, etc) and list based (e.g. – Unique) 
when retrieving list information.  Duplicate responses for count based selections (Study or Series) occur 
when more than a single response for a given UID is returned.  For list based selection (Image), 
duplicates occur when a duplicate image UID is returned. Duplicates are symptomatic of some DICOM 
incompatibility.  Multiple responses occur when more than single exam UID is returned and would 
typically only be allowed when validation is expected to find multiple exams on either the source or the 
destination (e.g. – two exams are intentionally merged during the migration).  These settings are 
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advanced capabilities that are only used for specific cases.  As such, the defaults are to Disallow these 
types of responses resulting in a failed validation step.  


	Migration Basics
	Overview
	Workflow

	Installation
	Prerequisites
	Main Install

	Getting Started
	Overview
	Types
	Editions
	Charge By
	Installing a License
	Creating a Migration
	Running a Migration

	User Interface Details
	Sessions / Segments Panel
	Session Configuration Dialog
	Segment Configuration Dialog
	/Exam Viewer
	Query Viewer
	History Dialog
	Operation Progress Panel
	Tool Bar
	Menu Bar

	Segments
	Overview
	Normal
	Specific
	List
	Priors
	Fixed

	Operations
	Query
	Move
	Validate


