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1. Compass Basics 

1.1. Overview  

Compass acts as a store and forward router for DICOM images, and can route from one or more 

Sources to one or more Destinations.  This process can be described in three phases.  First, a 

Source, or SCU, initiates communication with Compass by issuing a C-STORE request.  

Compass accepts this request, receives the DICOM image from the Source, and filters the 

incoming information based upon any user defined Filters for incoming images.  Next, Compass 

compares the image information against any user defined Rules and schedules the image to be 

sent to the Destination(s), or SCP(s), defined by any Rules that apply.  Finally, the image is 

filtered and sent to the determined Destination(s) at the scheduled time(s).  Sources, 

Destinations, Rules, and Filters are discussed in further detail in Sections 3.3, 3.4, 3.5, and 3.6. 

 

Compass is comprised of two parts: the Compass Service, which runs as a Windows Service, and 

the Compass user interface, which is used to configure the Compass Service and monitor the jobs 

that Compass is aware of.  The Compass GUI does not need to be running in order for the 

Compass service to run, accept, process, and send jobs. 



- 2 - 

 

Compass User Manual ©2011 Laurel Bridge Software, Inc. All Rights Reserved v 2.1.20 

2. Installation  

2.1. Prerequisites  

Laurel Bridge Compass utilizes several components known as prerequisites that must be installed 

for the application to work.  The prerequisites consist of: 

 
- Microsoft .NET Framework 3.5 
- Visual C++ Runtime Libraries (x86) 
- Windows Installer 3.1 
- Microsoft SQL Server Express 2005 SP3 

 

The main install executable (Setup.exe) will determine whether these prerequisites are needed 

and install them accordingly. 

2.2. Main Install  

After installing the prerequisites, the Compass installer (Compass.msi) will run.  For machines 

with an older version installed, this installer will upgrade any previous installation while 

maintaining any current configuration settings. 
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3. Gettin g Started 

3.1. Overview  

In order to route DICOM images, Compass must have at least one Source, one Destination, and 

one Rule defined. 

 

A Source describes an SCU that will issue C-STORE requests to Compass.  There is no limit on 

the number of Sources, though at least one must be defined.  A Source describes the SCU 

machine, Application Entity titles, transfer syntaxes, advanced association settings, and data 

Filters on the images received from the SCU. 

 

A Destination describes an SCP that will receive C-STORE requests from Compass.  There is no 

limit on the number of Destinations, though at least one must be defined.    A Destination 

describes the SCP machine, Application Entity titles, transfer syntaxes, advanced association 

settings, data Filters on the images sent to the SCP, the sending schedule, and the job activation 

mode, which describes how DICOM images are aggregated or split in associations. 

 

A Rule describes the criteria a DICOM image must meet in order to be sent to the specified 

Destination(s).  There is no limit on the number of Rules, though at least one must be defined.  A 

Rule contains one or more conditions: conditions based upon the association information, 

conditions based upon DICOM tag information, or custom user-defined conditions.  Each 

individual Rule can be specified such that any or all of the conditions must be met in order for 

the DICOM image to be tasked for the specified Destination(s). 

3.2. Installing a License  

The first step after launching Compass is to install a license.  When the About Laurel Bridge 

Compass dialog appears, click the Licenseé button, browse to the license file, and hit OK.  

Information on the status of the license, including when it expires, can be 

found on this dialog available at any time by clicking Help > About Laurel 

Bridge Compass. 

3.3. Creating a Source 

 A new Source can be created by selecting Edit > Optionsé from the menu 

and then selecting the Sources pane.  Press the green plus button located 

under the Sources list.  This will create a new Source with the name ñNew 

Source-?ò, where ? is the next available number starting at 0.  Source names 

are customizable and can be modified at any time by clicking on the name.  

The list of Sources may be reordered by selecting a Source and then pressing 

the up or down arrows directly to the right of the Sources list.  When an SCU 

requests an association with Compass the Sources list is processed from top 

to bottom and the first match found is used, therefore the ordering of the 

Sources may be important if potentially more than one could match. 



- 4 - 

 

Compass User Manual ©2011 Laurel Bridge Software, Inc. All Rights Reserved v 2.1.20 

 

Once a Source has been created the next step is to configure its settings. 

 

Settings 

 

Under the Compass heading, the AE Title that Compass will accept is listed.  The Allow Any 

checkbox can be selected to allow any value for that field. 

 

Under the Source Heading, settings include configuration 

options for the remote AE Title (AE title of the client), the 

remote Host:IP, the remote Port number, the Enabled status of 

the Source, an option to limit the number of concurrent 

associations, and the type of responses that are sent back to the 

Source for non-routed images.  The Allow Any checkbox 

following the  AE Title, Host/IP, and Port can be selected to 

allow any value for that field.  Select the Source Enabled 

checkbox to enable the specified Source; deselect it to 

temporarily refuse any connections from the specified Source.  

To limit the number of concurrent associations allowed by this 

Source check the Max Simultaneous checkbox and specify the 

desired number. 

 

The type of response from Compass that will be sent to the 

Source for non-routed images can also be configured.  Images 

fail to get routed to a Destination if they donôt match any of 

the defined Rules.  Compassô default behavior is to report an 

error back to the Source for a non-routed image; this is indicated by selecting the checkbox 

Report errors for non-routed images.  By deselecting this checkbox, Compass will always report 

back to the Source that it received the image successfully.  This behavior is desirable in a 

situation when Compass should not forward all of the images sent to it by this particular Source.  

For example, if all Ultrasound images with a particular Referring Physician need to be sent from 

a PACS to another Destination, but the PACS can only send all of its Ultrasound images and not 

simply a subset of them, then, by leaving the Report errors for non-routed images checkbox 

unchecked and defining a Rule to match the Referring Physician, only the desired images will be 

sent to the Destination. 

 

Under the Transfer Syntaxes heading, the list of transfer syntaxes that Compass will accept for 

the specified Source can be configured.  Add the desired Transfer Syntaxes to the list of accepted 

Transfer Syntaxes by selecting the desired Transfer Syntax in the combo box and adding it by 

pressing the provided button.  After building up the list with the desired Transfer Syntaxes, place 

them in the desired order by selecting each one and moving it up and down in the list by pressing 

the up and down arrows.  The supported Transfer Syntax list is evaluated top-to-bottom when a 

Source presents its requested presentation context list.  If the Favor Sourceôs Transfer Syntax 

checkbox is checked, then the Transfer Syntax list ordering proposed by the Source will be given 

priority; otherwise, the list as specified in Compass will be given priority. 
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Under the Storage Commit heading, a Source can optionally 

enable Storage Commitment.  If the Enabled checkbox is 

checked, Compass will accept all store commit requests for 

the given Compass Source.  Compass will respond with an 

ñacceptò response to the specified Host/IP and Port using 

the specified Compass AE Title and Remote AE Title. 

 

 

 

 

 

Under the Advanced heading, a user can give more in-depth 

control over how a Source communicates with Compass.  Data 

handling options, DIMSE settings, PDU settings, and socket 

settings are all areas which can be configured in finer detail 

when editing the Network options.  Verbose DICOM logging 

can be turned on or off on a per Source basis by selecting óOnô 

or óOffô in the Dicom Logging combo box. 

 

 

 

Filters can be created for 

any Source.  The list of 

Filter names may be 

reordered by selecting a 

Filter and then pressing the 

up or down arrows.  Filters 

in the list will be applied in 

order from top to bottom, so 

ordering is important.  See 

the section on Filters for a 

more in-depth description 

of filtering capabilities. 
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3.4. Creating a Destination  

 A new Destination can be created by selecting Edit > Optionsé from the menu 

and then selecting the Destinations pane.  Press the green plus button located 

under the Destinations list.  This will create a new Destination with the name 

ñNew Destination-?ò where ? is the next available number, starting at 0.  

Destination names are customizable and can be modified at any time by clicking 

on the name.  The list of Destinations may be reordered by selecting a 

Destination and then pressing the up or down arrows directly below the 

Destinations list.  Unlike Sources, there is no priority associated with 

Destination ordering; it is merely provided as a convenience. 

 

Once a Destination has been created the next step is to configure its settings. 

 

Under the Compass heading, settings include configuration options for the AE 

Title (Application Entity) and Host/IP.  

 

Under the Destination heading, settings include options for the AE Title, the Host/IP, the Port 

number, a Test button for testing the connection, an Is on LAN? checkbox, and the enabled status 

of the Destination.  Selecting the Destination Enabled checkbox will allow jobs to be sent to the 

specified Destination; deselect it to temporarily stop sending jobs to the specified Destination.  

Checking or unchecking the Is on LAN? checkbox will optimize network buffer sizes for that 

particular network topology. 

 

For both the Local AE Title and Remote AE Title, values can be set with a fixed value by selecting 

Fixed in their corresponding combo 

boxes.  Alternately, the AE titles 

can be set to either Source Calling or 

Source Called; this will use the 

calling or called AE title from the 

inbound association that created the 

job for this Destination.  In the rare 

case that an oubound job is made up 

of images that came from different 

clients using different AE titles, the 

AE titles from the first imageôs 

association will be used. 

 

Once values have been specified for 

the Local AE Title, the Remote AE 

Title, the Host/IP, and the Port, then 

the Test button can be clicked to 

issue a DICOM Verification request to the specified Destination.  A green check next to the Test 

button indicates a successful connection; a red X indicates a connection could not be made, or 

the connection was refused. Hover the mouse pointer over the X to read a tooltip with a message 

that further describes the failure. 
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Under the Transfer Syntaxes heading, the user can configure the list of allowable transfer 

syntaxes that Compass will negotiate with the specified Destination.  Add the desired transfer 

syntaxes to the list of accepted Transfer Syntaxes by selecting the desired transfer syntax in the 

combo box and adding it by pressing the provided button.  After building up the list with the 

desired Transfer Syntaxes, place them in the desired order by selecting each one and moving it 

up and down in the list by pressing the up and down arrows.  Selecting one of the options in the 

Mode combo box will also affect how Transfer Syntaxes are requested: 

 As Received or Destination Preferred ï attempts to send instances to the Destination in the 

transfer syntax they were received; otherwise attempts to send via the Destinationôs 

preferred transfer syntax from the list of enabled transfer syntaxes. 

 As Received or Compass Preferred ï  attempts to send instances to the Destination in the 

transfer syntax they were received; otherwise attempts to send via Compassô preferred 

transfer syntax from the list of enabled transfer syntaxes. 

 As Received ï attempts to send instances to the Destination in the transfer syntax they 

were received, and will fail otherwise. 

 Destination Preferred ï attempts to send instances to the Destination via the Destinationôs 

preferred transfer syntax from the list of enabled transfer syntaxes. 

 Compass Preferred ï attempts to send instances to the Destination via Compassô 

preferred transfer syntax from the list of enabled transfer syntaxes. 

 

Under the Jobs heading, settings include options which affect how and when jobs are sent to the 

Destination.  If the Stable Study Time checkbox is selected, images from the same study that 

arrive on separate associations will be combined and sent out on a single association, once the 

user-specified stable time has been reached.  If unchecked, outgoing jobs will only contain 

images from the same study that were received in the same association.  The Max Simultaneous 

checkbox allows the number of concurrent associations to the specified Destination to be limited 

to the specified value. The Initial Delay setting will delay jobs to this Destination by the specified 

number of minutes.  The Max Attempts setting defines the maximum number of send attempts.  

The Retry Delay will cause an unsuccessful job to be retried after the specified number of 

minutes.  Checking the Ignore Association Teardown Errors checkbox will result in the job being 

successfully sent if Compass receives all successful DIMSE responses from the Destination, 

even if the association is not properly released.  This functionality is occasionally necessary 

because some store servers do not properly respond to an association release request.  Checking 

the Treat Warnings as Success checkbox allows Compass to treat a job as successfully sent even 

if one of the Dimse response statuses specified a warning instead of success.  Checking the 

Heartbeat Sensing Enabled checkbox will cause Compass to verify that the Destination is 

available prior to attempting to send jobs to it.  If the Destination is unavailable, Compass will 

queue up the jobs for the Destination without attempting to send them.  If and when the 

Destination becomes available, Compass will begin sending the 

queued jobs.  Compass issues a DICOM Verification request and 

inspects the reply (or lack thereof) to determine if the Destination 

is available. 

 

Under the Advanced heading, a user can give more in-depth 

control over how Compass communicates with a Destination.  
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Filters and Network options are configured in the same fashion as Sources.  The Schedule 

specifies the time at which jobs are allowed to be sent to the Destination.  A green box for the 

given day and time means jobs may be sent at that time; a red box means that jobs may not be 

sent at that time.  This affects only the starting time of the job as a whole; a currently running job 

will not stop sending images once it has begun to transmit them. 

 

Each hour block represented by a green or red square may be toggled individually; alternatively, 

right-clicking on the schedule allows the schedule to be set to a commonly used setting.  Be 

aware that choosing one of these predefined settings will replace the currently specified 

schedule.  Verbose DICOM logging can be turned on or off on a per Destination basis by 

selecting On, Off, or After Failures in the Dicom Logging chooser. Selecting After Failures 

requires the number of failures before logging to be further specified. 

 

The Use Throughput Optimization Protocol checkbox controls whether Compass will use 

proprietary protocols to transfer jobs to this Destination. Compass TOPS requires that the 

Destination be another instance of Compass version 2.1.0 or greater. TOPS provides throughput 

enhancements for jobs with many instances as well as enhanced job restart capability in the event 

of an error mid-transfer (such as a temporary network failure).  

 

The Enable SSL checkbox specifies whether the Destination requires SSL. Use the Ignore 

Certificate Name Mismatch Errors and Allow Self-Signed Certificates checkboxes to relax the 

Compass certificate validation of the Destination. 

 

 

3.5. Creating a Rule 

A new Rule can be created by selecting Edit > Optionsé from the menu and then 

selecting the Rules pane.  Press the green plus button located under the Rules 

list.  This will create a new Rule with the name ñNew Rule -?ò where ? is the 

next available number, starting at 0.  Rule names are customizable and can be 

modified at any time by clicking on the name.  The list of Rules may be 

reordered by selecting a Rule and then pressing the up or down arrows directly 

to the right of the Rules list.  When Compass processes the list of Rules for each 

received image the Rules list is processed from top to bottom and the first match 

found is used, therefore the ordering of the Rules may be important if potentially 

more than one could match. 

 

Once a Rule has been created the next step is to configure its Conditions, 

Selected Destinations, and Rule Options. 

 

Conditions 

 

 A Ruleôs Conditions determine whether 

or not its Actions will be applied to an 

image being processed.  A Rule may have multiple conditions, in which case it may be specified 



- 9 - 

 

Compass User Manual ©2011 Laurel Bridge Software, Inc. All Rights Reserved v 2.1.20 

that either all the conditions must apply to the image or that only one condition must apply to the 

image in order for the Rule to match.  Another option is that the Rule always matches; 

effectively declaring it to have no Conditions.  Selecting one of three radio buttons, If ALL 

Conditions Match, If ANY Conditions Match, and Always, will implement one of these three 

scenarios. 

 

The Dicom Tag condition allows incoming images to be selected for this Rule based upon their 

Dicom Element Tags. 

 

 
 

The Association condition allows incoming images to be selected for this Rule based upon their 

incoming Dicom Association information. 

 

 
 

The Execute condition allows incoming images to be selected for this Rule based upon a custom, 

user-defined rule condition.  See the example towards the end of this user manual for an example 

of a custom rule condition implementation. 

 

 
 

 

Configure the condition based upon the desired test.  Conditions may be added or removed by 

pressing the green plus sign or the red minus sign located to the left of each condition. 

 

Rule Actions 

 

If all of the Conditions for the Rule pass then the image 

currently being processed will have the currently selected 

action applied: Discard Instance or Send to Selected 

Destinations.  To add another Destination to the Selected 

Destinations list, select the desired Destination in the Add 

Destination combo box and press the green plus sign.  To 

remove a Destination from the list, right-click on the desired 

Destination and choose Remove Selected in the context menu.  A predefined, special Destination 

exists called the Hold Queue.  Any jobs routed to the Hold Queue will wait there indefinitely until 

the user decides to perform an action on them, such as sending them to another Destination or 

deleting them. 

 

Rule Options 

 

Uncheck the Rule Enabled checkbox to disable the selected Rule.  If 

unchecked, the Rule will be passed over during Rule processing. 

 

Check the Stop Rule Processing On Match checkbox if no further 
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Rules in the Rules list should be processed if this Rule matches (Rules are processed sequentially 

from the top of the list to the bottom of the list).  If unchecked, Rule processing will proceed to 

the next Rule even if this Rule matches. 

 

Specify a number in the Priority number chooser to assign the order in which the job that the 

specified image contains will be processed.  1 is the highest priority, and 10 is the lowest 

priority.  If a job is populated with images that matched different rules containing different 

priorities, the job is assigned the highest priority of the matching rules.  Jobs with a higher 

priority will be sent before jobs with a lower priority.  If a Destination has multiple jobs with the 

same priority, the older job is processed first. 

 

 

 

 

3.6. Filters  

Filters allow an imageôs header data to be changed as Compass receives it from a Source or as 

Compass sends it out to a Destination.  Actions are only applied if the Conditions are met. 

 

A new Filter can be 

created by selecting Edit 

> Optionsé from the 

menu, selecting a Source 

or Destination, and then 

selecting the Filters edit 

link.  Press the green plus 

button located under the 

Filters list.  This will 

create a new Filter with 

the name ñNew Filter ?ò 

where ? is the next 

available number, 

starting at 0.  Filter 

names are customizable and can be modified at any time by clicking on the name.  The list of 

Filters may be reordered by selecting a Filter and then pressing the up or down arrows.  Filters 

are applied in order, top to bottom, so ordering is important. 

 

Another way to create a new Filter is to copy from another Source or Destination.  Pressing the 

ñCopy Froméò link in the upper-right section of the Filter Editor allows you to copy individual 

Filters defined in the other Sources and Destinations.  There is also an option to copy all the 

Filters from a specific Source or Destination by selecting the menu item named ñAllò listed 

below the defined Filters.  If a Filter already exists with the same name when copying a Filter, 

the new Filter will have an asterisk (*) appended to its name. 

 

Once a Filter has been created the next step is to configure its Conditions and Actions. 
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Conditions 

 

A Filterôs Conditions determine whether or not its 

Actions will be applied to the image being processed.  

A Filter may have multiple conditions, therefore an option is provided that all Conditions must 

match or any Conditions can match in order for the Filter to be applied.  Another configuration is 

to have no Conditions, thereby always matching. 

 

For each Condition select the Dicom Tag condition type (additional types may be added in the 

future).  Configure the rest of the Condition based upon the desired test.  Conditions may be 

removed by pressing the red minus sign located to the left of each condition, and sorted via the 

up and down arrow buttons. 

 

 

Actions 

 

If the Conditions testing was satisfied then any defined Actions will be applied to the image. 

 

The Change Case action changes the case of the selected tag to either upper-case or lower-case. 

 

 
 

The Copy action copies the tag specified in the From field to the tag specified in the To field. 

 

 
 

The Execute action executes a piece of custom code that adheres to a particular interface: 
public class DateComparisonFilter : IFilterAction 
{ 

public void ApplyAction(CFGGroup config, DicomSessionSettings dss, RelevantTagMarker tagMarker, 
ref DicomDataSet dds) 
 { 
  // custom code 
 } 
} 
 

 
 

The Find/Replace action changes the value of the selected tag via hardcoded values or regex 

values. 
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The Insert/Overwrite action creates the specified Tag (if it didnôt already exist) or overwrites the 

specified tag (if it did already exist) with the specified Value. 

 

 
 

The Mapping List action allows the user to specify an external file that lists match tags and 

replace tags.  When creating a Mapping List action in Compass, the user specifies the format of 

the mapping list file.  The example below shows that the mapping list file will contain three 

comma-separated fields: an accession number, a patient ID, and a patientôs name.  If the match 

tags on any given row match the current dataset, the values of the replace tags are substituted 

into the dataset.  Below is an example of a mapping list file that matches the format of the 

mapping list action: 

 

PIKR0004,PAT124,SMITH^JOSEPH 

ABC123,PAT45,MINER^STEVEN 

 

 
 

The Move action moves the tag from its original location to its final location.  Once moved, the 

tag will not being present in its original location. 

 

 
 

The New UID action replaces the Unique Identification (UID) value of the specified UID type tag 

in the Tag field with a new UID value. 

 

 
 

The Pad action pads the specified tag with the specified character.  The Left and Right radio 

buttons specify whether to pad the left or right side of the value.  The new total length of the tag 

value is specified by the Length field.  If the length of the original value is equal to or greater 

than the Length field, the value will not be changed. 
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The Prepend/Append action prepends or appends the specified text to the specified tagôs value. 

 

 
 

The Regex Substitution action performs a regular expression match on the specified tagôs value 

using the given Pattern.  It then replaces the value with the Replace string which may contain 

regex variables from the match.  The Test box can be filled with an example tag value and 

clicking the green arrow processes the test data. 

 

 
 

The Remove action removes the specified tag.  If the Only if empty checkbox is checked, the tag 

will be removed only if the specified tagôs value is empty. 

 

 
 

The Trim action removes the specified characters from the left, right, or both sides of the 

specified tagôs value.  

 

Original Attribute Sequence 

 

The original tag value of a filtered tag can optionally be stored in the original attribute sequence 

by checking the Create Original Attribute Sequence checkbox.  If left unchecked, the original 

values modified by the filter will not be recorded in the original attribute sequence. 

 

 
 

3.7. System Settings 

System settings can be configured by selecting Edit > Optionsé from the menu and then 

selecting the System pane. 

 

Application Logs 

 

Compass provides the ability to log a varying level of 

information to its application log file.  The location, name, and 

size of the log file are configurable.  The application log file is 

also implemented as a rolling log file, meaning that when the 

log file reaches the specified maximum file size a new 
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application log file with a new name will be created become the new application log.  The rolling 

log file name has an incrementing number in the filename which increments each time the log 

file rolls over to the new file.  It is also possible to configure how many of these rolling log files 

should be kept, as well as the verbosity of the log data.  This is helpful for a variety of reasons, 

such as being able to see in detail what is being communicated between Compass and other 

devices. 

 

Dicom Incoming 

 

Compass will begin listening for incoming associations at 

launch if the Enabled at Startup checkbox is selected. 

 

The port Compass uses to listen for Dicom association 

requests can be configured by specifying the port number in 

the Listen Port chooser. 

 

The maximum number of concurrent associations from 

Sources that Compass will process can be specified by using the Max Connections chooser.  This 

is the absolute maximum number of incoming concurrent connections; if a Source has its 

individual maximum connections specified higher than this number then this number takes 

precedence. 

 

The Optimize For chooser will direct Compass to optimize its network buffers for your particular 

network topology. If many of your Sources connect to Compass via the Internet it is 

recommended that you choose WAN for this setting. Otherwise, the default setting of LAN is 

appropriate. 

 

The Enable SSL checkbox will allow incoming encrypted connections to Compass. To properly 

configure incoming SSL connections, the Listen Port, SSL Certificate and/or Password must be 

set. The Listen Port is the port on which Compass will receive SSL encrypted Dicom 

associations. The SSL Certficate should be set to the location of the certificate that Compass 

should present for identification to clients. It is suggested that the certificate be a standard 

PKCS#12 certificate and it must contain an exportable private key. Finally, the Password must 

be set to the password for the private key in the certifcate. Using a certificate format that does 

not password protect the private key allows this setting to be ignored. 

 

The Store SOP classes accepted by 

Compass are configurable via the 

Supported SOP Classes table.  To add 

support for a new SOP class enter its UID 

in the UID text field, its name in the Name 

text field, and press the green plus button.  

To remove support for a particular SOP 

class simply select the desired SOP class, 

right-click for the context menu, and 

choose the Remove Selected menu item.  It is also possible to press the Delete key to remove the 
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selected SOP class(es).  To select a contiguous group of SOP classes for removal, select a SOP 

class by left-clicking it with the mouse and then select another SOP class while holding down the 

Shift key.  To select a non-contiguous group of SOP classes for removal, select each individual 

SOP class while holding down the Ctrl key.  Alternately, typing Ctrl+A will select all of the SOP 

classes in the table. 

 

Dicom Outgoing 

 

The maximum number of concurrent associations that Compass will 

use to connect to Destinations can be specified using the Max 

Connections chooser.  This is the absolute maximum number of 

outgoing concurrent connections; if a Destination has its individual 

maximum connections specified higher than this number then this 

number takes precedence. 

 

Compass will enable outgoing jobs at launch if  the Enabled at Startup checkbox is selected. 

 

 

Data Storage 

 

Compass provides the ability to specify the storage location 

for images.  A different path may be specified from the 

default by typing in a new location or selecting it from the 

folder browser.  Note that the newly specified directory must already exist, and Input and Output 

must be stopped in order to change the location.  The user may also configure how long sent jobs 

are kept via the Purge Sent Jobs control. 

 

 

Destination Heartbeat Sensing 

 

Each Destination defined in Compass has several 

ways of determining when jobs should be sent to 

that Destination.  One way is to enable the Heartbeat 

Sensing feature on a given Destination.  Each Destination that has this feature enabled will send 

a DICOM Verification request to the Destination at the frequency specified. 
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3.8. Notifications  

Reports can be configured by selecting Edit > Optionsé from 

the menu and then selecting the Notifications pane. 

 

Notifications can be sent for job failures and/or low disk 

space. If the Job Failure Notifications Enabled checkbox is 

checked, Compass will send an email detailing the failed jobs 

to the Notification Recipients at the specified frequency. The 

job information contained in the emails can be configured 

with the Email Columns chooser. 

 

If the Low Disk Space Notifications Enabled checkbox is 

checked and the computer has less disk space available than the threshold, Compass will send an 

email to the Notification Recipients at the specified frequency.  To add a new recipient press the 

green add button located beneath the list of Notification 

Recipients.  Specify the recipientôs email address and press 

the Enter key.  The sender of the email can be specified as 

well. 

 

It is necessary to include a valid Mail Server Configuration in 

order to send emails to the listed recipients.  At a minimum a 

Host and Port are required, and optionally SSL can be 

enabled by selecting the Enable SSL checkbox.  A Username 

and Password are also required if the mail server requires 

authentication. 
 

3.9. Enabling Input and Output  

To allow Compass to accept incoming association requests press the Start button on the Input 

toolbar.  To disable Compass from accepting any new incoming association requests press the 

Stop button on the Input toolbar.  Pressing Stop on the Input toolbar does not affect any currently 

open associations. 

 

To allow Compass to submit outgoing store jobs to Destinations press the Start button on the 

Output toolbar.  To disable Compass from submitting any new outgoing store jobs press the Stop 

button on the Output toolbar.  Pressing Stop on the Output toolbar does not affect any currently 

running jobs. 
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4. User Interface  Details  

4.1. Menu Bar  

A menu bar is available at the top of the main window: 

 

- File > Import Configuration: Imports an existing 

configuration file. 

- File > Export Configuration: Exports the current 

configuration to a chosen location. 

- File > Exit: Exits the program (after completing any incoming and outgoing associations). 

- Edit > Options: Opens the main options dialog. 

- View > Current Application Log: Opens the application log file. 

- View > Application Log Directory: Opens Windows Explorer to view the Compass log file 

directory. 

- View > Inbound Association History: Displays information regarding specific inbound 

associations.. 

- View > Destination Status: Displays the status of each Destination. 

- View > Active Associations: Displays a table containing the current inbound and outbound 

associations. 

- Help > Getting Started: Displays a ñGetting Startedò guide to introduce new users to 

Compass. 

- Help > User Manual: Opens the Compass user manual. 

- Help > About Laurel Bridge Compass: Displays an ñAboutò dialog containing program 

and license information. 

4.2. Tool Bar  

The Incoming components are available in the toolbar.  Pressing the 

Start button allows Compass to process incoming associations, while 

pressing the Stop button will cause Compass to no longer listen for 

new incoming associations.  Pressing the Stop button does not affect 

currently connected associations, as they are allowed to run to 

completion. 

 

The Outgoing components are available in the toolbar.  Pressing the 

Start button allows Compass to process outgoing jobs, while 

pressing the Stop button will cause Compass to not start any new 

outgoing jobs.  Pressing the Stop button does not affect currently 

running outgoing jobs, as they are allowed to run to completion. 
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4.3. Jobs 

The jobs table provides a filterable view of all the jobs in Compass.  Each column is sortable and 

optionally displayed.  Any column header can be left-clicked in order to sort by that column.  

Additionally, any column 

header can be right-

clicked on in order to 

configure which columns 

are displayed.  The View 

control allows the user to 

display only jobs 

matching the defined 

criteria.  For example, the 

Jobs table can be configured to only 

display patient names that contain óCarlô 

and have study dates before April 14, 

2009 (see picture).  Any configured filter 

can be saved via the Save Current Filter 

button and assigned a name for easy 

retrieval at a later time.  

 

The jobs table also provides the ability to perform certain actions on selected jobs.  A single job 

can be selected simply by left-clicking on the particular job row.  To select a contiguous group of 

jobs, the user can left-click a particular job, and then left-click another job while holding down 

the Shift key. To select individual jobs, the user can left-click the desired jobs while holding 

down the Ctrl key. After selecting the desired jobs, the user can right-click to display the list of 

relevant actions.  Possible choices are: Detailsé, Keep and Send To, Remove and Send To, Retry, 

Retry To, Set Priority, Copy Job Images Toé, and Remove. 

Details View 






